ASKBOT - error fix« Wróć do listy pytań

again
Wysłane przez mrmucha
Zadane przez 20/04/2018 08:08
0

error –

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
 
   mod_wsgi (pid=29371): Target WSGcript '/var/www/muszak_askbot/django.wsgi' cannot be loaded as Python module.
   mod_wsgi (pid=29371): SystemExit exception raised by WSGcript '/var/www/muszak_askbot/django.wsgi' ignored.
   Traceback (most recent call last):
     File "/var/www/muszak_askbot/django.wsgi", line 17, in 
       application = get_wsgi_application()
     File "/usr/local/lib/python2.7/dist-packages/django/core/wsgi.py", line 14, in get_wsgi_application
       django.setup()
     File "/usr/local/lib/python2.7/dist-packages/django/__init__.py", line 18, in setup
       apps.populate(settings.INSTALLED_APPS)
     File "/usr/local/lib/python2.7/dist-packages/django/apps/registry.py", line 108, in populate
       app_config.import_models(all_models)
     File "/usr/local/lib/python2.7/dist-packages/django/apps/config.py", line 198, in import_models
   lf.models_module = import_module(models_module_name)
     File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module
       __import__(name)
     File "/usr/local/lib/python2.7/dist-packages/askbot/models/__init__.py", line 2, in 
     tartup_procedures.run()
     File "/usr/local/lib/python2.7/dist-packages/askbot/startup_procedures.py", line 1089, in run
     ys.exit(1)
 ystemExit: 1
^C
root@debian-test:~# tail -f /var/log/httpd/muszak.eu.askbot/error_log
       app_config.import_models(all_models)
     File "/usr/local/lib/python2.7/dist-packages/django/apps/config.py", line 198, in import_models
   lf.models_module = import_module(models_module_name)
     File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module
       __import__(name)
     File "/usr/local/lib/python2.7/dist-packages/askbot/models/__init__.py", line 2, in 
     tartup_procedures.run()
     File "/usr/local/lib/python2.7/dist-packages/askbot/startup_procedures.py", line 1089, in run
     ys.exit(1)
 ystemExit: 1
  handling WSGxception
  Traceback (most recent call last):
    File "/var/www/muszak_askbot/django.wsgi", line 17, in 
      application = get_wsgi_application()
    File "/usr/local/lib/python2.7/dist-packages/django/core/wsgi.py", line 14, in get_wsgi_application
      django.setup()
    File "/usr/local/lib/python2.7/dist-packages/django/__init__.py", line 18, in setup
      apps.populate(settings.INSTALLED_APPS)
    File "/usr/local/lib/python2.7/dist-packages/django/apps/registry.py", line 78, in populate
    aise RuntimeError("populate(sn't reentrant")
untimeError: populate(sn't reentrant
 
   mod_wsgi (pid=29371): Target WSGcript '/var/www/muszak_askbot/django.wsgi' cannot be loaded as Python module.
   mod_wsgi (pid=29371): SystemExit exception raised by WSGcript '/var/www/muszak_askbot/django.wsgi' ignored.
   Traceback (most recent call last):
     File "/var/www/muszak_askbot/django.wsgi", line 17, in 
       application = get_wsgi_application()
     File "/usr/local/lib/python2.7/dist-packages/django/core/wsgi.py", line 14, in get_wsgi_application
       django.setup()
     File "/usr/local/lib/python2.7/dist-packages/django/__init__.py", line 18, in setup
       apps.populate(settings.INSTALLED_APPS)
     File "/usr/local/lib/python2.7/dist-packages/django/apps/registry.py", line 108, in populate
       app_config.import_models(all_models)
     File "/usr/local/lib/python2.7/dist-packages/django/apps/config.py", line 198, in import_models
   lf.models_module = import_module(models_module_name)
     File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module
       __import__(name)
     File "/usr/local/lib/python2.7/dist-packages/askbot/models/__init__.py", line 2, in 
     tartup_procedures.run()
     File "/usr/local/lib/python2.7/dist-packages/askbot/startup_procedures.py", line 1089, in run
     ys.exit(1)
 ystemExit: 1
^C
root@debian-test:~# tail -f /var/log/httpd/muszak.eu.askbot/error_log
       app_config.import_models(all_models)
     File "/usr/local/lib/python2.7/dist-packages/django/apps/config.py", line 198, in import_models
   lf.models_module = import_module(models_module_name)
     File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module
       __import__(name)
     File "/usr/local/lib/python2.7/dist-packages/askbot/models/__init__.py", line 2, in 
     tartup_procedures.run()
     File "/usr/local/lib/python2.7/dist-packages/askbot/startup_procedures.py", line 1089, in run
     ys.exit(1)
 ystemExit: 1
  handling WSGxception
  Traceback (most recent call last):
    File "/var/www/muszak_askbot/django.wsgi", line 17, in 
      application = get_wsgi_application()
    File "/usr/local/lib/python2.7/dist-packages/django/core/wsgi.py", line 14, in get_wsgi_application
      django.setup()
    File "/usr/local/lib/python2.7/dist-packages/django/__init__.py", line 18, in setup
      apps.populate(settings.INSTALLED_APPS)
    File "/usr/local/lib/python2.7/dist-packages/django/apps/registry.py", line 78, in populate
    aise RuntimeError("populate(sn't reentrant")
untimeError: populate(sn't reentrant

fix – add to settings.py at botton this line
ASKBOT_SELF_TEST = False

Wysłane przez mrmucha
Odpowiedziane 20/04/2018 08:09