Forum

proxmox: stuck in u...
 
Notifications
Clear all

proxmox: stuck in upgrade from 5 to 6 to 7

1 Posty
1 Users
0 Likes
1,817 Widok
0
Topic starter
INFO: status = running
INFO: Can't locate Authen/PAM.pm in @INC (you may need to install the Authen::PAM module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/x86_64-linux-gnu/perl5/5.24 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at /usr/share/perl5/PVE/Auth/PAM.pm line 8, <DATA> line 755.
INFO: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/Auth/PAM.pm line 8, <DATA> line 755.
INFO: Compilation failed in require at /usr/share/perl5/PVE/AccessControl.pm line 26, <DATA> line 755.
INFO: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/AccessControl.pm line 26, <DATA> line 755.
INFO: Compilation failed in require at /usr/share/perl5/PVE/RPCEnvironment.pm line 14, <DATA> line 755.
INFO: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/RPCEnvironment.pm line 14, <DATA> line 755.
INFO: Compilation failed in require at /usr/share/perl5/PVE/CLI/qm.pm line 20, <DATA> line 755.
INFO: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/CLI/qm.pm line 20, <DATA> line 755.
INFO: Compilation failed in require at /usr/sbin/qm line 6, <DATA> line 755.
INFO: BEGIN failed--compilation aborted at /usr/sbin/qm line 6, <DATA> line 755.
ERROR: Backup of VM 105 failed - command 'qm set 105 --lock backup' failed: exit code 2
INFO: Failed at 2022-06-02 11:54:09
INFO: Backup job finished with
W: (pve-apt-hook) !! WARNING !!
W: (pve-apt-hook) You are attempting to remove the meta-package 'proxmox-ve'!
W: (pve-apt-hook)
W: (pve-apt-hook) If you really want to permanently remove 'proxmox-ve' from your system, run the following command
W: (pve-apt-hook)       touch '/please-remove-proxmox-ve'
W: (pve-apt-hook) run apt purge proxmox-ve to remove the meta-package
W: (pve-apt-hook) and repeat your apt invocation.
W: (pve-apt-hook)
W: (pve-apt-hook) If you are unsure why 'proxmox-ve' would be removed, please verify
W: (pve-apt-hook)       - your APT repository settings
W: (pve-apt-hook)       - that you are using 'apt full-upgrade' to upgrade your system
E: Sub-process /usr/share/proxmox-ve/pve-apt-hook returned an error code (1)
E: Failure running script /usr/share/proxmox-ve/pve-apt-hook
libev-perl : Depends: perlapi-5.24.1
 libfile-sync-perl : Depends: perlapi-5.24.1
 libfilesys-df-perl : Depends: perlapi-5.24.1
 libgail-common : Depends: libgtk2.0-0 (>= 2.24.32) but 2.24.31-2 is to be installed
 libgail18 : Depends: libgtk2.0-0 😊 2.24.32-3) but 2.24.31-2 is to be installed
 libhtml-parser-perl : Depends: perlapi-5.24.1
 libintl-xs-perl : Depends: perlapi-5.24.1
 libjson-xs-perl : Depends: perlapi-5.24.1
 liblinux-inotify2-perl : Depends: perlapi-5.24.1
 liblocale-gettext-perl : PreDepends: perlapi-5.24.1
 libmath-random-isaac-xs-perl : Depends: perlapi-5.24.1
 libnet-dbus-perl : Depends: perlapi-5.24.1
 libnet-ssleay-perl : Depends: perlapi-5.24.1
 libpve-u2f-server-perl : Depends: perl (>= 5.28.1-6) but 5.24.1-3+deb9u7 is to be installed
 libpython2.7 : Depends: libpython2.7-stdlib 😊 2.7.16-2+deb10u1) but 2.7.13-2+deb9u6 is to be installed
 librados2-perl : Depends: perl (>= 5.28.1-6) but 5.24.1-3+deb9u7 is to be installed
 librgw2 : Depends: libcurl4 (>= 7.28.0) but it is not going to be installed
 librrds-perl : Depends: perlapi-5.24.1
 libsocket6-perl : Depends: perlapi-5.24.1
 libtemplate-perl : Depends: perlapi-5.24.1
 libterm-readline-gnu-perl : Depends: perl (>= 5.28.1-3) but 5.24.1-3+deb9u7 is to be installed
 libtext-iconv-perl : Depends: perlapi-5.24.1
 libuuid-perl : Depends: perlapi-5.24.1
 libxml-libxml-perl : Depends: perl (>= 5.28.1-4) but 5.24.1-3+deb9u7 is to be installed
 libxml-parser-perl : Depends: perlapi-5.24.1
1 Answer
0
Topic starter

In my experience it's possible to jump from 5 to 7. There was no other way out because of the package conflict.

  1. edit /etc/apt/sources.list
  2. deb  http://ftp.debian.org/debian  bullseye main contrib
    deb  http://ftp.debian.org/debian  bullseye-updates main contrib
    deb  http://download.proxmox.com/debian/pve  bullseye pve-no-subscription
    deb  http://security.debian.org/debian-security  bullseye-security main contrib
    
  3. edit /etc/apt/sources.list.d/ceph.list
  4. deb  http://download.proxmox.com/debian/ceph-octopus  bullseye main
  5. type: apt dist-upgrade
  6. now you have to deal with "remove proxmox-ve", ok, type (all nodes should still working fine)
    touch '/please-remove-proxmox-ve'
  7. type: apt dist-upgrade
  8. if errors pop up during installation just type apt --fix-broken install and retype apt dist-upgrade
  9. apt install pve-manager
  10. apt install proxmox-ve

REMEMBER:

  1. do not restart any vm now (it's imposible to start again!)
  2. all nodes would be running on old node pv kernel until restart (first node under datacenter)
  3. it's impossible to start up again any node on old kernel (until pv restart)
  4. shutdown all vm's
  5. restart pv node
  6. start again VM's, done :)

 

Odpowied┼║

Author Name

Author Email

Your question *

 
Preview 0 Revisions Saved
Share: